Du hast eine Frage? Stell sie der t3n-Community!

? Beispielfragen

Um selbst eine Frage online zu stellen, melde dich bitte an.

Zur Anmeldung

TYPO3 4.5 über Medien Youtube Video einbinden?

12 Punkte

von knalltuete  Newbie  vor über 3 Jahren

Ich möchte ein Youtube Video in TYPO3 4.5 einbinden. Ich habe sonst immer rgmediaimages verwendet, allerdings soll TYPO3 4.5 ja von Haus aus Videos von externen Anbietern wie Youtube einbinden können. Ich habe hierzu die URL des Youtube Videos unter “Relativer Pfad oder URL” eingebunden. Allerdings bekomme ich kein Video im Frontend zu Gesicht.
Was mache ich falsch? Wurde die Funktion doch nicht integriert?

Nachträglich bearbeitet am 13.03.13 16:19

7 Antworten

0 Punkte

von fnagel  Geek  vor über 3 Jahren

Einfach die URL (mit allem) in das Pfad Feld kopieren. Bei mir klappt das.

0 Punkte

von ursaberlin  Newbie  vor über 3 Jahren

Bei mir das gleiche Problem, wie bei knalltuete.

Als Lösung trage ich nicht die URL http://www.youtube.com/watch?v=[YOUTUBEID]] in den Pfad ein, sondern http://www.youtube.com/v/[YOUTUBEID]] und deaktiviere den Haken bei Flash Player nutzen. Danach erscheint der native Youtube Player.

0 Punkte

von knalltuete  Newbie  vor über 3 Jahren

Vielen Dank ursaberlin! Das funktioniert wunderbar ;)

Hast du oder vielleicht jemand anders vielleicht auch noch einen Fix für Vimeo? Denn das funktioniert leider auch nicht bei mir.. Wenn ich z.B. http://vimeo.com/20461921 eingebe dann wird auch nichts angezeigt!

Ist das vielleicht irgendwo auch dokumentiert? Das wäre natürlich super!

Kommentare

  • admaster: Solltest Du noch keine Lösung gefunden haben – die Extension WEC Content Element (wec_contentelements) ist eine Alternative / “Notlösung”.

    vor über 3 Jahren
  • knalltuete: Genau das wollte ich mit der Aktion vermeiden. Warum eine Extension nutzen wenn es TYPO3 auch von Haus aus kann. Aber trotzdem vielen Dank für den Ratschlag! :)

    vor über 3 Jahren

Melde dich an, um einen Kommentar zu schreiben.

0 Punkte

von steffengebert  Rookie  vor über 3 Jahren

Ich hab das eben mal probiert – der vimeo-Link klappt bei mir auch problemlos (nur die Player-Option deaktivieren).
Und diese YouTube-URL klappt bei mir auch: http://www.youtube.com/watch?v=t8G94Dyo80U (also ohne das in /v/ umzubauen.
Ihr könnt euch mal den Code in typo3/sysext/cms/tslib/class.tslib_mediawizardcoreprovider.php anschaun, wie das da gelöst wird.

Steffen

Kommentare

  • lobster_1956: einzig das Problem iPhone/iPad bleibt irgendwie
    wie richtet man das Medienelement ein dass bei Geräten ohne Flash auch eine Ausgabe erfolgt… ???

    vor über 2 Jahren

Melde dich an, um einen Kommentar zu schreiben.

0 Punkte

von rowild  Newbie  vor ca einem Jahr

…auch wenn dieser Post schon sehr alt ist: Die automatische Umschaltung auf ein ipad-lesbares Format funktioniert nur dann, wenn das Youtube-Video via iframe und embed integriert wird. Zumindest lässt sich dies so einem Blog-Eintrag Youtubes entnehmen: http://apiblog.youtube.com/2010/07/new-way-to-embed-youtube-videos.html

0 Punkte

von kyburzwebdesign  Newbie  vor ca einem Jahr

Eine weitere Frage zu dieser zwar etwas alten Kommentarliste:
Wie kann ich den Flashplayer standardmässig deaktivieren? Hat das jemand schon mal gemacht? Einfach so, dass ich den Player nicht jedesmal beim Einbinden von Videos von Hand deaktivieren muss?

0 Punkte

von john.denver  Newbie  vor ca einem Jahr

Hier gibt es einen schönen Erklärungsfilm zur Einbindung von Medien in TYPO3:
http://www.youtube.com/watch?v=33MlW_DZrtk

Antwort schreiben

Um eine Antwort schreiben zu können, sollest du dich zuvor anmelden.

Zur Anmeldung

Kennst Du schon unser t3n Magazin?

t3n-Newsletter t3n-Newsletter
Top-Themen der Woche für Web-Pioniere
Jetzt kostenlos
anmelden
Diesen Hinweis verbergen